Issue Description:
An ADP connector was purchased and already connected to the Deputy account, but now it shows Not connected
Replication Steps:
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Log into Deputy via web browser
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Select your name > Integrations
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Connected tab > Select location > Select ADP application
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Configuration tab > Shows Not connected
Cause:
- The ADP API site is down
- ADP performed system maintenance
- The ADP connector has been suspended/cancelled
- The email address changed for the user who connected the ADP/Deputy accounts
- The user who connected the ADP/Deputy accounts was archived in Deputy
- The user who connected the ADP/Deputy accounts was deleted from Deputy
- The user who connected the ADP/Deputy accounts had their access level changed in Deputy
- The ADP connector tokens expired
Solution:
Solution 1: The ADP API site is down:
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Contact ADP or wait for the status to be reinstated
Solution 2: ADP performed system maintenance:
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Go through the Deputy Connector Setup Guide to re-establish the connection
Solution 3: The ADP connector has been suspended/cancelled:
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Log into your ADP account and review the connector status
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If it shows as suspended or cancelled, send an email to adpmarketplace@adp.com to have the connector reinstated
Solution 4: The email address changed for the user who connected the ADP/Deputy accounts:
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Log into your Deputy account
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Log into your ADP account
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Update the email address in both accounts to be the same
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Go through the Deputy Connector Setup Guide to re-establish the connection
Solution 5: The user who connected the ADP/Deputy accounts was archived in Deputy:
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Follow the steps in Archiving and Unarchiving Team Members to unarchive the user
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Go through the Deputy Connector Setup Guide to re-establish the connection
Solution 6: The user who connected the ADP/Deputy accounts was deleted from Deputy
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Add the user back into Deputy with the same email address they had previously
OR
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Have a different System Administrator or Location Manager establish the connection using the Deputy Connector Setup Guide
Solution 7: The user who connected the ADP/Deputy accounts had their access level changed in Deputy:
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Follow the steps in How to Change Employee Access to System Administrator Access to change the user back to System Administrator or Location Manager
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Go through the Deputy Connector Setup Guide to re-establish the connection
Solution 8: The ADP connector tokens expired:
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Create a support ticket with Deputy to confirm the tokens are active.