Issue Description:

When attempting to send timesheets to ADP, receive error message: Export Failed : The date range selected (XXX ~ XXX) was not found in ADP as an open Pay Frequency. Please check ADP's available Pay Frequency date range and select the same range in Deputy before trying again. Current Pay Frequencies in ADP : (XXX ~ XXX)

Export Failed : The date range selected (XXX ~ XXX) was not found in ADP as an open Pay Frequency. Please check ADP's available Pay Frequency date range and select the same range in Deputy before trying again. Current Pay Frequencies in ADP : (XXX ~ XXX)

Replication Steps:

  1. Log into Deputy via web browser

  2. Timesheets tab > Export Timesheets

  3. Select location > Select employees > Export Selected Items

  4. Select an ADP option from the dropdown > Export

  5. Receive error message


Cause:

  • Exporting timesheets for a period that does not match the ADP pay period


Solution:

  • Adjust the timesheet period under Export timesheets (snapshot below) to match the ADP pay period

    While in the 'Export Timesheets' screen, click on the date bar and adjust the date range to match the ADP pay period dates.
  • If you have already processed the pay run that covers the ADP pay period, process the payment directly in ADP rather than exporting the timesheets from Deputy. You can use the timesheets in Deputy as a reference only.

Did this answer your question?