Issue Description:

When submitting an ad-hoc timesheet, you receive an error message stating Time Sheet approval Failed. Selected time sheet must not overlap an existing one of the same employee

Time Sheet approval Failed. Selected time sheet must not overlap an existing one of the same employee

Replication Steps:

  1. Log into Deputy via web browser

  2. Timesheets tab > Approve Timesheets

  3. Add Time Sheet

  4. Select Employee and Date of shift > Add Time Sheet

  5. Populate details > Select Approve & Next or Approve

  6. Receive error message


Cause:

  • The area entered is a non-work area AND the button to enable submission of non-work areas is disabled

  • The location entered has a timezone conflicting with an approved timesheet for another location


Solution:

Solution 1: The area entered is a non-work area AND the button to enable submission of non-work areas is disabled

  1. Locations tab > Find the location > Edit Settings

    Select the 'Locations' tab from the top menu. Find the location in question and select 'Edit Settings'
  2. Areas tab > Find the area > Edit

    On the left-hand side, select the 'Areas' tab. Find the area and select the 'Edit' button.
  3. Advanced area settings

    At the bottom of the pop-up window, select 'Advanced area settings'
  4. Don't count towards worked time? is set to YES

    'Don't count towards worked time' is set to 'YES'
  5. Select your name > Business Settings

    Select your name in the upper-right hand corner to open a dropdown menu where you can select 'Business Settings'
  6. Timesheets tab > Find Allow employees to submit timesheets in a non-worked area and select the dial to turn ON > Apply Changes

Select the 'Timesheets' tab which is the 3rd tab from the right. Find 'Allow employees to submit timesheets in a non-worked area' toward the bottom and click the dial to turn this ON. Then select 'Apply Changes'.

Solution 2: The location entered has a timezone conflicting with an approved timesheet for another location

  1. Timesheets tab > Approve Timesheets

    Select the 'Timesheets' tab from the top menu to open a drop down menu where you can select 'Approve Timesheets'
  2. Select the location > Select the impacted employee > Notice the date range defaults to a pay period range

    In the upper left-hand corner, select the location you want. Then on the left-hand side, select the impacted employee. Notice the date range has defaulted to a pay period range
  3. Click on the date range > Select 1 day before and 1 day after the date causing the error message > Select Done

    Click on the date range to open the calendar menu. On the left calendar, select a date 1 day prior to the date causing the error message. On the right calendar select 1 day after the date causing the error message. In the lower right-hand corner, select 'Done'.
    1. Example: If entering a timesheet for October 24th causes the error, adjust the date range to reflect October 23rd - October 25th

  4. Take note of all locations listed under the Area of Work column

    Under the 'Area of Work' column, take note of the locations listed.
  5. Locations tab > Search for a location > Edit Settings

    Select the 'Locations' tab from the top menu. Search for one of the locations and select 'Edit Settings'.
  6. General tab > Timezone field

    On the left-hand side, select the 'General' tab. Locate the 'Timezone' field to confirm if the selection is correct. If it's incorrect, select the correct timezone then click 'Save' in the upper right-hand corner.
    1. If the timezone is incorrect, update the timezone > Save

    2. If the timezone is correct, repeat steps 5 & 6 for the remaining locations

Did this answer your question?