Issue Description:

An ADP connector was purchased and already connected to the Deputy account, but now it shows Not connected

Within the ADP application 'Configuration' tab, it shows 'Not connected'

Replication Steps:

  1. Log into Deputy via web browser

  2. Select your name > Integrations

  3. Connected tab > Select location > Select ADP application

  4. Configuration tab > Shows Not connected


Cause:

  • The ADP API site is down

  • ADP performed system maintenance

  • The ADP connector has been suspended/cancelled

  • The email address changed for the user who connected the ADP/Deputy accounts

  • The user who connected the ADP/Deputy accounts was archived in Deputy

  • The user who connected the ADP/Deputy accounts was deleted from Deputy

  • The user who connected the ADP/Deputy accounts had their access level changed in Deputy

  • The ADP connector tokens expired


Solution:

Solution 1: The ADP API site is down:

  • Contact ADP or wait for the status to be reinstated

Solution 2: ADP performed system maintenance:

Solution 3: The ADP connector has been suspended/cancelled:

  1. Log into your ADP account and review the connector status

  2. If it shows as suspended or cancelled, send an email to adpmarketplace@adp.com to have the connector reinstated

Solution 4: The email address changed for the user who connected the ADP/Deputy accounts:

  1. Log into your Deputy account

  2. Log into your ADP account

  3. Update the email address in both accounts to be the same

  4. Go through the Deputy Connector Setup Guide to re-establish the connection

Solution 5: The user who connected the ADP/Deputy accounts was archived in Deputy:

  1. Follow the steps in Archiving and Unarchiving Team Members to unarchive the user

  2. Go through the Deputy Connector Setup Guide to re-establish the connection

Solution 6: The user who connected the ADP/Deputy accounts was deleted from Deputy

  • Add the user back into Deputy with the same email address they had previously

OR

Solution 7: The user who connected the ADP/Deputy accounts had their access level changed in Deputy:

  1. Follow the steps in How to Change Employee Access to System Administrator Access to change the user back to System Administrator or Location Manager

  2. Go through the Deputy Connector Setup Guide to re-establish the connection

Solution 8: The ADP connector tokens expired:

  • Create a support ticket with Deputy to confirm the tokens are active.

Did this answer your question?