What is the change and when is it happening?

Deputy shall be updating the Transport Layer Security (TLS) version from TLS v1.0 to TLS v1.2 across Deputy’s entire application and website. This means the Deputy service will no longer support any version less than TLS v1.2.

This change will be occurring on Thursday 30th November 9:00 am (AEDT).

How do I know if I’m impacted and what is the impact?

Deputy users will receive a connection error while trying to communicate with or access the Deputy application or website. Please note that the connection error is due to the fact that your browser or device does not support the latest secured version of TLS.

You can refer to this link here to check whether your browser/device supports TLS v1.2.

What action do I need to take?

All latest devices/operating systems/internet browsers support TLS v1.2. However, if you encounter any errors, you may need to update your browser version/device firmware to ensure you are secured and able to access Deputy.

How can I get more information?

For more information on whether your browser/device supports TLS v1.2, you can refer to this page.

If you have further questions, please reach out to Customer Support by emailing experience@deputy.com.

Did this answer your question?